Call recording is down in UAE

Incident Report for Skyvera

Resolved

The incident has been resolved
Posted Apr 24, 2026 - 19:07 UTC

Monitoring

The issue with call recordings has been resolved and new recordings are functioning correctly. We will continue to monitor this.
Posted Apr 23, 2026 - 23:22 UTC

Investigating

Old recordings are not accessible, and new ones are not being recorded in the UAE. We are investigating the issue.
Posted Apr 23, 2026 - 19:41 UTC
This incident affected: Kandy UAE (Call Services UAE).